Fix “You’re using a version of snapchat” Error on iPhone in iOS 11

Ever since its release, Snapchat has a very strict policy for jailbreak tweaks. In an effort to block the jailbroken iOS devices, Snapchat introduces different checks.

iPhone, iPad and iPod Touch owners after updating their iDevices to iOS 11 are getting error that reads:

“You’re using a version of Snapchat or operating system that’s no longer supported. Please upgrade your device’s operating system and update to the newest app version to use Snapchat. Thanks! ”.

You re using a version of snapchat Error

This post will cover different methods to fix this problem.

Fix “You’re using a version of snapchat” Error on iPhone

Mostly this error is due to outdated version of Snapchat. So first method to fix this problem is to either update Snapchat to latest version or re-install it. For that, follow the steps blow:

  1. Delete the Snapchat app.
  2. Launch AppStore and search for Snapchat. Proceed with its installation.

If the issue still persists, you need to soft restart your iPhone. For that, follow the steps below:

  1. Press and hold Power + Home button until you see Apple Logo.
  2. Once Apple logo appears, release both buttons.

Let us know if you have any question related to this tutorial on how to fix the Snapchat “You’re using a version of snapchat” error in iOS 11.

iOS Developer with over 8 years of experience in Jailbreak. Loves to help users solve their iPhone/iPad problems through step by step tutorials.

Leave a Comment